Please login or register.

Login with username, password and session length
 

News:

Happy 2021 !!!


Author Topic: Marvel/DC FASERIP Stats to FF Stats Conversor  (Read 858 times)

Offline oktokels

  • Sr. Member
  • Posts: 370
Marvel/DC FASERIP Stats to FF Stats Conversor
« on: July 21, 2019, 11:27:24 PM »
Hello everybody, i got to finally translate my little conversor for all you people [have to check the quality of the translation though, so bear for now with any errors you may find  :wacko:]. This is great for all of you who are making hero files out of RPG stats that you may find in some websites or rpg gaming books. These especifically convert marvel FASERIP [fighting, agility, strength, endurance, reason, instinct and psyche] values to Freedom force stats. Plus it converts values for weight, superspeed, flying, regeneration and talent for acrobatics, martial arts and weapons. The process of conversion is taking directly from TaskmasterX's conversion guide, which is in pdf format somewhere around this site [i have a copy for anyone interested]
---------------------------------------------------------------------------
HOW TO

1. First you need a software called PSEint. This is a program that runs a pseudocode for programation students. I knew of this program in classes, since i studied that. The program is in spanish though, but the conversor itself is in english. You can get it here --> http://pseint.sourceforge.net/

2. Once you download and start the program, you will get this screen:
Spoiler: ShowHide


3. Go to file [or "archivo"] ,then open FFXENG.psc, or copy the text code that i'll post here and paste it directly on the program screen.

4. Run the code by pressing F9, it'll open a window and you'll have to enter values, usually a number or "yes" or "no", like that, without mayuscules. Like this:

Spoiler: ShowHide


5. Once you enter all values, you'll get this screen:

Spoiler: ShowHide


6. And that's it !

---------------------------------------------------------------

WHERE TO FIND A CHARACTER RPG STAT

1. Usually i go first to Ben Reilly Marvel RPG page: http://www.angelfire.com/comics/benriely/index.html There's a TON of characters here, including marvel and dc heroes and villains, including the cinematic universe of both.

2. Once you find the character you're looking for, the information will be presented this way:
Spoiler: ShowHide
Captain America
Steve Rogers

F) Am50--->Fighting value
A) In40---> Agility value
S) Rm30---> Strength value
E) Rm30---> Endurance value
R) Ex20---> Reason value
I) In40---> Instinct value
P) Am50---> Psyche value

Health: 150 ---> Hp value


1. The weight value i usually get it from marvel or dc wikia, it converts the weight to ff weight, so the character can get a  knockback the way it should be. The energy value i get it by taking the highest number between reason, instinct and psyche, so the energy value is 50 in captain america's case.

2. Captain America has resistance to toxins, regeneration [ty6], hyper running [Pr4 superspeed], doesn't fly and have the acrobatics talent, martial arts talent, and weapon talent, so i enter "yes" or "no", as the conversor ask. The resistance a character could have should be natural, inherent to his own body, and not by external means, like an armor or shield. As for regeneration, it could be fast healing, lesser regeneration, lesser regeneration plus or regenerative. AS for flying, could be levitate, flier, and fast flier, but usually with mages i tend to give them the levitate attribute, for visual purposes.

3. The acrobatics talents add +1 to agility stat, tumbling talent gives the character the acrobatic attribute [no dmg when falling]. The character could have a martial arts talent of a,b,c,d or e. All of them are described on taskmaster conversion guide, but martial arts C is wrestler attribute, martial arts E adds +1 to fighting speed, the others count as +1 to magnitude, stun or knockback. Same for weapon talent. A character that has a higher psyche value, gets a unbeliever, disciplined or level headed defense.

4. If you cant find the character you are looking for, you may find it on other websites or rpg books that may have different formats for rpg values, so you may find some guide here http://www.classicmarvelforever.com/cms/d20-conversion.htmlto help you convert from like dungeons and dragons rpg stats to FASERIP stats. Here is another page for PDF rpg stats resources http://mshgamer.com/downloads/book-resources/. And that's it, any doubts only ask ! Hope it works for everybody.

Here is the link for the .psc file: http://www.mediafire.com/file/ragznexhckog22i/FFXENG.rar/file
And here is the code:

Spoiler: ShowHide
Code: [Select]
Proceso conversion
   

Definir pelea, agilidad, fuerza, energia, durabilidad, psyche como entero;
Definir supervelocidad, resistencias, regeneracion como caracter
definir valorpes como caracter


Escribir "What its weight lbs?"
Leer peso;
Escribir "Enter fighting value:"
Leer pelea;
Escribir "Enter agility value:"
Leer agilidad;
Escribir "Enter strength value:"
Leer fuerza;
Escribir "Enter durability value:"
Leer durabilidad;
Escribir "Enter energy value:"
Leer energia;
Escribir "Enter psyche value:"
Leer psyche;
Escribir "Enter HP value:"
Leer hp;
Escribir "Have resistances?"
Leer resistencias;
Escribir "Have regeneration?"
Leer regeneracion;
Si regeneracion="yes" Entonces
Escribir "What is the value?"
Leer valoreg;
Finsi
Escribir "Have superspeed?"
Leer supervelocidad;
Si supervelocidad="yes" Entonces
Escribir "What is the value"
Leer valorsv;
FinSi
Escribir "Can fly?"
Leer volar;
Si volar="yes" Entonces
escribir "What is the value"
Leer valorvl;
FinSi
Escribir "Have acrobat talent?"
Leer acrobat;
Escribir "Have martial arts talent?"
Leer artmar;
Escribir "Have weapon talent?"
Leer arma;


Si valorvl=0 entonces
valorvl2=1
FinSi
Si valorvl=1 entonces
valorvl2=1
FinSi
Si valorvl=4 Entonces
valorvl2=3
FinSi
Si valorvl=6 Entonces
valorvl2=4
FinSi
Si valorvl>=10 y valorvl<=20 Entonces
valorvl2=5
FinSi
Si valorvl=30 Entonces
valorvl2=6
FinSi
Si valorvl=40 Entonces
valorvl2=7
FinSi
Si valorvl>=50 y valorvl<=75 Entonces
valorvl2=8
FinSi
Si valorvl=100 Entonces
valorvl2=9
FInsi
Si valorvl>=150 Entonces
valorvl2=10
FinSi



si valoreg>=2 y valoreg<=10 Entonces
valoreg2="Fast Healing"
FinSi
si valoreg>=20 y valoreg<=40 Entonces
valoreg2="Lesser Regeneration"
FinSi
si valoreg>=50 y valoreg<=75 Entonces
valoreg2="Lesser Regeneration Plus"
FinSi
si valoreg>=100 y valoreg<=500 Entonces
valoreg2="Regenerative"
FinSi
si valoreg>=1000 Entonces
valoreg2="Regenerative plus"
FinSi
si valoreg=0 Entonces
valoreg2= "NONE"
FinSi

si peso=0 Entonces
valorpes= "No weight"
FinSi
si peso>=1 y peso<=20 Entonces
valorpes= "50 LBS"
FinSi
si peso>=21 y peso<=30 Entonces
valorpes= "60 LBS"
FinSi
si peso>=31 y peso<=40 Entonces
valorpes= "70 LBS"
FinSi
si peso>=41 y peso<=50 Entonces
valorpes= "80 LBS"
FinSi
si peso>=51 y peso<=60 Entonces
valorpes= "90 LBS"
FinSi
si peso>=61 y peso<=70 Entonces
valorpes= "100 LBS"
FinSi
si peso>=71 y peso<=80 Entonces
valorpes= "110 LBS"
FinSi
si peso>=81 y peso<=90 Entonces
valorpes= "120 LBS"
FinSi
si peso>=91 y peso<=100 Entonces
valorpes= "130 LBS"
FinSi
si peso>=101 y peso<=125 Entonces
valorpes= "140 LBS"
FinSi
si peso>=126 y peso<=150 Entonces
valorpes= "150 LBS"
FinSi
si peso>=151 y peso<=200 Entonces
valorpes= "170 LBS"
FinSi
si peso>=201 y peso<=250 Entonces
valorpes= "190 LBS"
FinSi
si peso>=251 y peso<=350 Entonces
valorpes= "220 LBS"
FinSi
si peso>=351 y peso<=450 Entonces
valorpes= "240 LBS"
FinSi
si peso>=451 y peso<=550 Entonces
valorpes= "260 LBS"
FinSi
si peso>=551 y peso<=650 Entonces
valorpes= "280 LBS"
FinSi
si peso>=651 y peso<=750 Entonces
valorpes= "300 LBS"
FinSi
si peso>=751 y peso<=850 Entonces
valorpes= "330 LBS"
FinSi
si peso>=851 y peso<=1000 Entonces
valorpes= "350 LBS"
FinSi
si peso>=1001 y peso<=1500 Entonces
valorpes= "390 LBS"
FinSi
si peso>=1501 y peso<=2000 Entonces
valorpes= "440 LBS"
FinSi
si peso>=2001 y peso<=5000 Entonces
valorpes= "480 LBS"
FinSi
si peso>=5001 y peso<=11000 Entonces
valorpes= "520 LBS"
FinSi
si peso>=11001 Entonces
valorpes= "520 LBS + density control"
FinSi
si peso=0 Entonces
valorpes= "0"
FinSi

si pelea <= 2 entonces
resultadop = "    0"
Finsi
si pelea = 4 entonces
resultadop = "    1 HIT NORMAL"
Finsi
si pelea = 6 entonces
resultadop = "    1 HIT NORMAL"
Finsi
si pelea = 10 entonces
resultadop = "    1 HIT NORMAL"
FinSi
si pelea = 20 entonces
resultadop = "    1 HIT NORMAL"
FinSi
si pelea = 30 entonces
resultadop = "    1 HIT, 2 HITS=LOW ENERGY"
FinSi
si pelea = 40 entonces
resultadop = "    2 HITS, 3 HITS=MED ENERGY"
FinSi
si pelea = 50 entonces
resultadop = "    2 HITS, 3 HITS=LOW, 4+HITS=MED, FAST"
FinSi
si pelea>=75 entonces
resultadop = "    2-3 HITS, 4 HITS=LOW, VERY FAST"
FinSi


si agilidad <= 2 entonces
resultadoa = "1 VL AC"
Finsi
si agilidad = 4 entonces
resultadoa = "2 VL AC"
Finsi
si agilidad = 6 entonces
resultadoa = "3 LOW AC"
Finsi
si agilidad = 10 entonces
resultadoa = "3 LOW AC"
Finsi
si agilidad = 20 entonces
resultadoa = "4 LOW AC"
FinSi
si agilidad = 30 entonces
resultadoa = "5 MED AC"
FinSi
si agilidad = 40 entonces
resultadoa = "6 MED AC"
FinSi
si agilidad = 50 entonces
resultadoa = "7 HIGH AC"
FinSi
si agilidad = 75 entonces
resultadoa = "8 HIGH AC"
FinSi
si agilidad = 100 entonces
resultadoa = "9 VHIGH AC"
FinSi
si agilidad>=150 entonces
resultadoa = "10 VHIGH AC"
FinSi


si fuerza <= 2 entonces
resultadof = "1 VLOW DMG"
FInsi
si fuerza = 4 entonces
resultadof = "2 VLOW DMG"
FinSi
si fuerza = 6 entonces
resultadof = "2 VLOW DMG"
Finsi
si fuerza = 10 entonces
resultadof = "3 LOW DMG"
FinSi
si fuerza = 20 entonces
resultadof = "3 LOW DMG"
FinSi
si fuerza = 30 entonces
resultadof = "4 MED DMG, LOW KB"
FinSi
si fuerza = 40 entonces
resultadof = "5 MED DMG, LOW KB"
FinSi
si fuerza = 50 entonces
resultadof = "6 HIGH DMG, MED KB"
FinSi
si fuerza = 75 entonces
resultadof = "7 HIGH DMG, MED KB"
FinSi
si fuerza = 100 entonces
resultadof = "8 HIGH DMG, HIGH KB"
FinSi
si fuerza = 150 entonces
resultadof = "9 HIGH DMG, HIGH KB"
FinSi
si fuerza = 200 entonces
resultadof = "9 HIGH DMG, HIGH KB"
FinSi
si fuerza = 500 entonces
resultadof = "10 HIGH DMG, EX KB"
FinSi
si fuerza>=1000 entonces
resultadof = "10 VHIGH DMG, EX KB"
FinSi


si durabilidad <= 2 entonces
resultadod1 = 1
Finsi
si durabilidad = 4 entonces
resultadod1 = 2
FinSi
si durabilidad = 6 entonces
resultadod1 = 3
Finsi
si durabilidad = 10 entonces
resultadod1 = 3
FinSi
si durabilidad = 20 entonces
resultadod1 = 4
FinSi
si durabilidad = 30 entonces
resultadod1 = 4
FinSi
si durabilidad = 40 entonces
resultadod1 = 5
FinSi
si durabilidad = 50 entonces
resultadod1 = 6
FinSi
si durabilidad = 75 entonces
resultadod1 = 7
FinSi
si durabilidad = 100 entonces
resultadod1 = 8
FinSi
si durabilidad = 150 entonces
resultadod1 = 9
FinSi
si durabilidad = 200 entonces
resultadod1 = 9
FinSi
si durabilidad>= 500 entonces
resultadod1 = 10
FinSi



si hp>=1 y hp<=10 entonces
resultadod = 1
Finsi
si hp>=11 y hp<=25 entonces
resultadod = 2
FinSi
si hp>=26 y hp<=40 entonces
resultadod = 3
FinSi
si hp>=41 y hp<=49 entonces
si durabilidad>fuerza y durabilidad>agilidad y durabilidad>pelea y resistencias="yes" entonces
resultadod = resultadod1
Finsi
Finsi
si hp>=41 y hp<=49 entonces
si durabilidad<=fuerza o durabilidad<=agilidad o durabilidad<=pelea o resistencias="no" entonces
resultadod = 3
FinSi
Finsi
si hp>=50 y hp<=55 entonces
si durabilidad>fuerza y durabilidad>agilidad y durabilidad>pelea y fuerza>=10 entonces
resultadod = resultadod1
finsi
finsi
si hp>=50 y hp<=55 entonces
si durabilidad<=fuerza o durabilidad<=agilidad o durabilidad<=pelea o fuerza<10 entonces
resultadod = 3
FinSi
Finsi
si hp=56 entonces
si durabilidad<=fuerza o durabilidad<=agilidad o durabilidad<=pelea o fuerza<10 entonces
resultadod = 4
FinSi
finsi
si hp=56 entonces   
si fuerza>=10 y durabilidad>fuerza y durabilidad>agilidad y durabilidad>pelea entonces
resultadod = resultadod1
FinSi
Finsi
si hp>=57 y hp<=69 entonces
si durabilidad>fuerza y durabilidad>agilidad y durabilidad>pelea entonces
resultadod = resultadod1

finsi
finsi
si hp>=57 y hp<=69 entonces
si durabilidad<=fuerza o durabilidad<=agilidad o durabilidad<=pelea entonces
resultadod = 4
FinSi
FInsi
si hp>=70 y hp<=90 entonces
resultadod = 4
FinSi
si hp>=91 y hp<=105 entonces
si durabilidad>fuerza y durabilidad>agilidad y durabilidad>pelea entonces
resultadod = resultadod1
FinSi
finsi
si hp>=91 y hp<=105 entonces
si durabilidad<=fuerza o durabilidad<=agilidad o durabilidad<=pelea entonces
resultadod = 4
FinSi
Finsi
si hp>=106 y hp<=109 entonces
si fuerza<=20 y resistencias="no" o regeneracion="no" entonces
resultadod = 4
FinSi
finsi
si hp>=106 y hp<=109 entonces
si fuerza>20 y resistencias="yes" o regeneracion="yes" entonces
resultadod = 4
FinSi
FInsi
si hp=110 entonces
si fuerza<=20  o resistencias="no" o regeneracion="no" entonces
resultadod = 4
FinSi
finsi
si hp=110 entonces
si fuerza>20 y  resistencias="yes" o regeneracion="yes" entonces
resultadod = 5
FinSi
Finsi
si hp>=111 y hp<=120 entonces
si durabilidad>fuerza y durabilidad>agilidad y durabilidad>pelea entonces
resultadod = resultadod1
FinSi
finsi
si hp>=111 y hp<=120 entonces
si durabilidad<=fuerza o durabilidad<=agilidad o durabilidad<=pelea entonces
resultadod = 5
FinSi
FInsi
si hp>=121 y hp<=130 entonces
resultadod = 5
FinSi
si hp>=131 y hp<=140 entonces
si durabilidad>fuerza y durabilidad>agilidad y durabilidad>pelea entonces
resultadod = resultadod1
FinSi
finsi
si hp>=131 y hp<=140 entonces
si durabilidad<=fuerza o durabilidad<=agilidad o durabilidad<=pelea y resistencias="si" entonces
resultadod = 5
FinSi
finsi
si hp>=131 y hp<=140 entonces
si durabilidad<=fuerza o durabilidad<=agilidad o durabilidad<=pelea o resistencias="no" entonces
resultadod = 4
FinSi
FinSi
si hp>=141 y hp<=160 entonces
si durabilidad>fuerza y durabilidad>agilidad y durabilidad>pelea entonces
resultadod = resultadod1
FinSi
finsi
si hp>=141 y hp<=160 entonces
si durabilidad<=fuerza o durabilidad<=agilidad o durabilidad<=pelea entonces
resultadod = 5
FinSi
FInsi
si hp>=161 y hp<=190 entonces
si durabilidad>fuerza y durabilidad>agilidad y durabilidad>pelea entonces
resultadod = resultadod1
FinSi
finsi
si hp>=161 y hp<=190 entonces
si durabilidad<=fuerza o durabilidad<=agilidad o durabilidad<=pelea entonces
resultadod = 6
FinSi
Finsi
si hp>=191 y hp<=280 entonces
si durabilidad>fuerza y durabilidad>agilidad y durabilidad>pelea entonces
resultadod = resultadod1
FinSi
finsi
si hp>=191 y hp<=280 entonces
si durabilidad<=fuerza o durabilidad<=agilidad o durabilidad<=pelea entonces
resultadod = 7
FinSi
FInsi
si hp>=281 y hp<=400 entonces
si durabilidad>fuerza y durabilidad>agilidad y durabilidad>pelea entonces
resultadod = resultadod1
FinSi
finsi
si hp>=281 y hp<=400 entonces
si durabilidad<=fuerza o durabilidad<=agilidad o durabilidad<=pelea entonces
resultadod = 8
FinSi
Finsi
si hp>=401 y hp<=1000 entonces
si durabilidad>fuerza y durabilidad>agilidad y durabilidad>pelea entonces
resultadod = resultadod1
finsi
finsi
si hp>=401 y hp<=1000 entonces
si durabilidad<=fuerza o durabilidad<=agilidad o durabilidad<=pelea entonces
resultadod = 9
FinSi
FInsi
si hp>=1001 entonces
si durabilidad>fuerza y durabilidad>agilidad y durabilidad>pelea entonces
resultadod = resultadod1
FinSi
finsi
si hp>=1001 entonces
si durabilidad<=fuerza o durabilidad<=agilidad o durabilidad<=pelea entonces
resultadod = 10
FinSi
finsi

si durabilidad<20 entonces
resultadov = 3
Finsi
si durabilidad>=20 entonces
resultadov = 4
FinSi
si durabilidad>=20 y agilidad=40 o agilidad=50 entonces
resultadov = 5
FinSi
si durabilidad>=20 y agilidad=75 o agilidad=100 entonces
resultadov = 6
FinSi
si durabilidad>=20 y agilidad>=150 entonces
resultadov = 7
FinSi

si energia = 2 entonces
resultadoe = 1
Finsi
si energia = 4 entonces
resultadoe = 2
FinSi
si energia = 6 entonces
resultadoe = 3
Finsi
si energia = 10 entonces
resultadoe = 3
FinSi
si energia = 20 entonces
resultadoe = 4
FinSi
si energia = 30 entonces
resultadoe = 4
FinSi
si energia = 40 entonces
resultadoe = 5
FinSi
si energia = 50 entonces
resultadoe = 6
FinSi
si energia = 75 entonces
resultadoe = 7
FinSi
si energia = 100 entonces
resultadoe = 8
FinSi
si energia = 150 entonces
resultadoe = 9
FinSi
si energia = 200 entonces
resultadoe = 9
FinSi
si energia>=500 entonces
resultadoe = 10
FinSi

si psyche < 40 Entonces
resultadops= "NONE"
FinSi
si psyche = 40 entonces
resultadops = "UN or DIS"
Finsi
si psyche = 50 entonces
resultadops = "UN or DIS"
FinSi
si psyche = 75 entonces
resultadops = "LH+U or LH+D or LH"
Finsi
si psyche = 100 entonces
resultadops = "LH+U or LH +D or LH"
FinSi
si psyche>=150 entonces
resultadops = "LH+U+D or LH+U+D or LH+U+D"
Finsi

Si acrobat = "yes" Entonces
valorac= "+ 1 AGILITY"
FinSi
Si acrobat = "no" Entonces
valorac= "NONE"
FinSi


Si artmar = "yes" Entonces
valorartm= "    + 1 MELEE STUN, SWIFT or GRAPPLE ATK & DEF"
FinSi
Si artmar = "no" Entonces
valorartm= "        0"
FinSi


Si arma = "yes" Entonces
valorarm= "    + 1 WEAPON STUN, SWIFT, HITS, DMG or ACC"
FinSi
Si arma = "no" Entonces
valorarm= "        0"
FinSi

si valorsv<=1 Entonces
valorsv1= 1
FinSi
si valorsv=2 Entonces
valorsv1= 2
FinSi
si valorsv=4 Entonces
valorsv1= 3
FinSi
si valorsv=6 Entonces
valorsv1= 4
FinSi
si valorsv>=10 y valorsv<=20 Entonces
valorsv1= 5
FinSi
si valorsv=30 Entonces
valorsv1= 6
Finsi
si valorsv=40 Entonces
valorsv1= 7
Finsi
si valorsv>=50 y valorsv<=75 Entonces
valorsv1= 8
Finsi
si valorsv=100 Entonces
valorsv1= 9
Finsi
si valorsv>=150 Entonces
valorsv1= 10
Finsi

Si supervelocidad="yes" Entonces
Resultadov=valorsv1;
sino
Si supervelocidad="no" Entonces
resultadov=resultadov
finsi
FinSi

si valorvl2<resultadov Entonces
resultadovl= "Levitate"
FinSi
si valorvl2>=resultadov y valorvl2<=resultadov+2 Entonces
resultadovl="Flier"
FinSi
Si valorvl2>=resultadov+3 Entonces
resultadovl="Flier + Fast Flier"
FinSi
Si volar = "no" Entonces
resultadovl= "NONE"
FinSi

Escribir " ";
Escribir " WEIGHT:    ", valorpes;
Escribir " ------------------ ";
Escribir "STRENGTH : ", resultadof;
Escribir "SPEED    : ", resultadov;
Escribir "AGILITY  : ", resultadoa;
Escribir "ENDURANCE: ", resultadod;
Escribir "ENERGY   : ", resultadoe;
Escribir " ------------------ ";
Escribir "FIGHTING: ";
Escribir, resultadop;
Escribir "MELEE COMBAT: ";
Escribir valorartm;
Escribir "WEAPON COMBAT: ";
Escribir valorarm;
Escribir " ------------------ ";
Escribir "FLIER: ", resultadovl;
Escribir "ACROBATICS: ", valorac;
Escribir "PSYCHE: ", resultadops;
Escribir "REGENERATION: ", valoreg2;

FinProceso


« Last Edit: July 24, 2019, 07:00:45 PM by oktokels »

Offline oktokels

  • Sr. Member
  • Posts: 370
Re: Marvel/DC FASERIP Stats to FF Stats Conversor
« Reply #1 on: July 21, 2019, 11:47:30 PM »
- Next to strenght value, the conversor shows the output dmg a character should do, and next to agility value show the accuracy for ranged attacks.

- When a character has a higher fighting value, it shows how many contacts the character should do with melee attacks, how much should cost and the speed of the attack, something like this: 2 HITS, 3 HITS= LOW, 4+HITS=MED, FAST, this means that the character can do a fast melee attack of 2 contacts at no ep cost, 3 contacts at low ep cost and 4 or more contacts at medium ep cost,
« Last Edit: July 21, 2019, 11:51:39 PM by oktokels »

Offline spydermann93

  • Hero Member
  • Posts: 4379
Re: Marvel/DC FASERIP Stats to FF Stats Conversor
« Reply #2 on: July 22, 2019, 03:20:33 AM »
Very cool, Oktokels! :thumbup:

This could be really handy in the future.