Please login or register.

Login with username, password and session length
 

News:

Happy 20th Birthday, Freedom Force !!!


Author Topic: White/Glare out on part of model in game?  (Read 3567 times)

Offline SickAlice

  • One-Eyed Willy
  • Hero Member
  • Posts: 2855
  • I'm of a mind to make some mookie.
    • The Litterbox aka MeanJellybean
White/Glare out on part of model in game?
« on: June 08, 2015, 01:41:59 AM »
 :ffvstr:
That's about it the size of it without knowing the technicals



I skoped together a nif importing parts from a different 3d model. In my 3d program is everything looks perfect. In Ctool2 everything is fine (left image). In the ingame character previews (make character, select, choose fx/animation) everything is fine. In game however part of the mesh is glared out (right image). From the screenshot it appears all white though that isn't the full case. Closer to the pelvis are yellowish streaks as well. It's noteworthy that the model was in separate parts and that piece that's flawed was it's own separate piece prior to be joined with the rest (arms, hair, horns, eyes, teeth, so forth). All parts came from the same exact model and were textured and finished in the same program using the same method. I've tried a few things in Nifskope but nothing worked. Tried both tga and dds but also no result. This may be an issue of a different nature, I dunno, though it seemed localized to the model piece to me.
Any ideas? Thanks.

Offline Cyber Burn

  • Hero Member
  • Posts: 8863
Re: White/Glare out on part of model in game?
« Reply #1 on: June 08, 2015, 02:13:51 AM »
Maybe a second pair of eyes could help. If you want to send it my way, I'd be glad to take a look at it.

Offline SickAlice

  • One-Eyed Willy
  • Hero Member
  • Posts: 2855
  • I'm of a mind to make some mookie.
    • The Litterbox aka MeanJellybean
Re: White/Glare out on part of model in game?
« Reply #2 on: June 08, 2015, 03:47:25 AM »
Sure. I'll just link it here. I've seriously never encountered this and all my go to tricks don't seem to be doing anything.
http://catman.freedomforceforever.com/temp/SugarmanBeta.rar

Offline Cyber Burn

  • Hero Member
  • Posts: 8863
Re: White/Glare out on part of model in game?
« Reply #3 on: June 08, 2015, 05:22:50 AM »
This is odd, I'm not able to replicate the effect that you're seeing. Maybe I'm using different settings in-game than you are? Looking at it in NifSkope, the body and the upper arms are attached, yet from your pic, only the body is being affected. I'll go back through it tomorrow though, being half asleep, maybe I'm missing something.

Offline Cyber Burn

  • Hero Member
  • Posts: 8863
Re: White/Glare out on part of model in game?
« Reply #4 on: June 08, 2015, 03:21:43 PM »
Using the secondary Skin, I'm getting a slight Yellow Highlight during the game, but nothing to the level that I see in your Pic. Going through it in NifSkope, comparing the "Male_Basic" part of the Mesh with the "Sugarman" Part of the Mesh, the only real differences that I am seeing so far, is: 1) the location of the "NiAlphaProperty"; and 2) under the "Editable_Mesh_9" for "Sugarman", there are only 2 properties, while the "Editable_Mesh_12" under the "Male_Basic" has 3 properties. Unfortunately, I don't know enough about the technical aspects here to understand the cause/effect relation here.

Offline SickAlice

  • One-Eyed Willy
  • Hero Member
  • Posts: 2855
  • I'm of a mind to make some mookie.
    • The Litterbox aka MeanJellybean
Re: White/Glare out on part of model in game?
« Reply #5 on: June 08, 2015, 05:09:24 PM »
Thanks. I'm convinced it has to be with the model itself since that one piece of a whole is where the issue is it. I don't know what this would do but maybe I'll try making separate parts for the Sugarman body, one specifically for that piece instead of joining the objects into one like I was doing previously. Perhaps the flaw occurred when I joined the models in my 3d program or in the least I can find out whether to rule that one out or not.

Offline windblown

  • Hero Member
  • Posts: 843
Re: White/Glare out on part of model in game?
« Reply #6 on: June 08, 2015, 08:15:27 PM »
I don't get that effect either, the skope is fine for me in game  :huh:

Offline spydermann93

  • Titans
  • Hero Member
  • Posts: 4458
Re: White/Glare out on part of model in game?
« Reply #7 on: June 08, 2015, 08:40:49 PM »
I have the same problem as SA.  His body is all white, but his arms, his hair, his weapons, and his legs all appear fine.

I'll check on my desktop and see if it looks any different.

Offline daglob

  • Shape-Shifting Silly-Putty Android
  • Hero Member
  • Posts: 9745
  • Da Glob
Re: White/Glare out on part of model in game?
« Reply #8 on: June 08, 2015, 10:36:46 PM »
For what it's worth, I have a problem if the "glow" texture is missing. So, if there is no glow.whatever, I add a totally black texture, and that solves the problem. I have a similar problem with some meshes if the reflection texture is missing-then the mesh looks like it's made of colored glass or metal.

Offline Cyber Burn

  • Hero Member
  • Posts: 8863
Re: White/Glare out on part of model in game?
« Reply #9 on: June 08, 2015, 11:01:34 PM »
For what it's worth, I have a problem if the "glow" texture is missing. So, if there is no glow.whatever, I add a totally black texture, and that solves the problem. I have a similar problem with some meshes if the reflection texture is missing-then the mesh looks like it's made of colored glass or metal.

If you want to send me a couple of those Meshes, I'd be willing to take a look at them for you, maybe see if it's within my Skill Level to fix.

Offline SickAlice

  • One-Eyed Willy
  • Hero Member
  • Posts: 2855
  • I'm of a mind to make some mookie.
    • The Litterbox aka MeanJellybean
Re: White/Glare out on part of model in game?
« Reply #10 on: June 09, 2015, 01:58:58 AM »
I tried using that model part separately but got the same result. I double checked the 3d models but there isn't anything different about that part then the other pieces.
Checked glow and refl settings, everything's as it should be in the nif and all zero black textures accounted for in the directory. At a loss here. A few of you say you aren't having the issue. I have another graphics problem were attached pieces on meshes won't stay in place and fly all about, especially anything attached to the heads. I resolved this by turning off shadows, something I found in the archives but don't know why that actually works. Here are my settings:

ATI Mobility Radeon HD 4200 series graphics card on Windows 7 x64 OS, all the common drivers and then some updated and accounted for.

Game graphics settings:

Resolution: 640x480x32
Detail Level: Custom
Character Detail: High
Object Shadows: All
Character Shadows: No shadow
Fragment Detail: Maximum
- gloss map: checked
- ambient objects: checked
- decals: checked

----
Thanks for any and all help. Just can't lock in it though I'm a little fascinated at the same time here.

Offline Cyber Burn

  • Hero Member
  • Posts: 8863
Re: White/Glare out on part of model in game?
« Reply #11 on: June 09, 2015, 02:33:22 AM »
If it helps, here are my settings:


Offline spydermann93

  • Titans
  • Hero Member
  • Posts: 4458
Re: White/Glare out on part of model in game?
« Reply #12 on: June 09, 2015, 02:39:50 AM »
Ok, the body is white when shadows are on.

Offline SickAlice

  • One-Eyed Willy
  • Hero Member
  • Posts: 2855
  • I'm of a mind to make some mookie.
    • The Litterbox aka MeanJellybean
Re: White/Glare out on part of model in game?
« Reply #13 on: June 09, 2015, 03:43:57 AM »
Okay that resolves the in game display end of things. I went in and started changing them one by one to see where the fault is here, starting with the shadows of course. Okay I stopped and jammed out to the cover of Zero Wing by MegaDriver that I replaced the games theme with for awhile like I always do then onto the testing.

- Turning object shadows to none resolves it. I guess I can't have shadows with my graphics card which is fine with me. I don't mod or skin those anyway.

Leave the following two questions:

- Whats special that makes that one specific .obj react in this way?
- Should I finish and release and the nif (skinning is all it needs now) and just put a warning about  this in the notes or hold back on it?

Thanks again for the help friends. Your all awesome.

Offline spydermann93

  • Titans
  • Hero Member
  • Posts: 4458
Re: White/Glare out on part of model in game?
« Reply #14 on: June 09, 2015, 04:11:05 AM »
I used to play without shadows, but then I noticed that a few number of FX don't show up without shadows (like Thug Grenade and Centurion Spear).

It bugs me when certain things don't show up while other things do.  That's just me, though, and whatever you decide is fine with me.

Offline Cyber Burn

  • Hero Member
  • Posts: 8863
Re: White/Glare out on part of model in game?
« Reply #15 on: June 09, 2015, 04:14:12 AM »
While I have noticed a few FX not working correctly, it's usually been because of the Camera Angle. Unfortunately, I haven't figured out a fix to that yet.

As for the Mesh in question, you've put quite a bit of work into it, I'd hate to see it not get released now.

Offline spydermann93

  • Titans
  • Hero Member
  • Posts: 4458
Re: White/Glare out on part of model in game?
« Reply #16 on: June 09, 2015, 04:19:04 AM »
While I have noticed a few FX not working correctly, it's usually been because of the Camera Angle. Unfortunately, I haven't figured out a fix to that yet.

As for the Mesh in question, you've put quite a bit of work into it, I'd hate to see it not get released now.

Exactly!

Offline SickAlice

  • One-Eyed Willy
  • Hero Member
  • Posts: 2855
  • I'm of a mind to make some mookie.
    • The Litterbox aka MeanJellybean
Re: White/Glare out on part of model in game?
« Reply #17 on: June 09, 2015, 04:23:44 AM »
I don't play as much unless it's an occasional mod. I only use it mostly to see how nifs look in game since CTool is unreliable. This is the only time I've seen this one though so I could probably keep object shadows really. I can always toggle that if the need arises now that I know what's up. Still need to address the possibility of getting a graphics patch going someday.

For Sugar Man I'm open to a vote (count 2 then) on this one since ultimately it's not for me. Sorry to say I can't even remember who originally requested this one (it was last year sometime I think?). It seems it works for most of you and the other option is wait to see if I can fix the problem which of course is a long shot since I've no idea what to do to it. Though it wouldn't be improper to release it as a Beta, wouldn't be a first for me either. On the other hand I have a lot of stuff on my drive that's just sitting there over one or two snags. I dunno, I'll leave it up to you peeps, take a count and then go from there. Seems like it's going to be a go so I'll go do the texture tonight.

Offline crimsonquill

  • Sound Master
  • Hero Member
  • Posts: 2316
  • One Voice To Rule Them All
    • CrimsonQuill Productions
Re: White/Glare out on part of model in game?
« Reply #18 on: June 09, 2015, 07:04:29 AM »
For Sugar Man I'm open to a vote (count 2 then) on this one since ultimately it's not for me. Sorry to say I can't even remember who originally requested this one (it was last year sometime I think?). It seems it works for most of you and the other option is wait to see if I can fix the problem which of course is a long shot since I've no idea what to do to it. Though it wouldn't be improper to release it as a Beta, wouldn't be a first for me either. On the other hand I have a lot of stuff on my drive that's just sitting there over one or two snags. I dunno, I'll leave it up to you peeps, take a count and then go from there. Seems like it's going to be a go so I'll go do the texture tonight.

I vote for release as well. It's great work and would hate to see it shelved.

- CQ
"He said let there be light... CLICK! It was a lightbulb. And It was good."

Offline SickAlice

  • One-Eyed Willy
  • Hero Member
  • Posts: 2855
  • I'm of a mind to make some mookie.
    • The Litterbox aka MeanJellybean
Re: White/Glare out on part of model in game?
« Reply #19 on: June 09, 2015, 05:59:28 PM »
Three works for me then. I'll have to make a note to sometime scour the Blender and Max forums and get to the root of this though. Sort of pains me to just let a problem stick around. I'm retentive like that.  <_<

Offline WyldFyre

  • Hero Member
  • Posts: 888
  • Feel the Burn!
    • FF Museum
Re: White/Glare out on part of model in game?
« Reply #20 on: June 10, 2015, 01:49:29 AM »
I vote yes as well. 

It seems there were a lot of graphical problems in FF1 and FF2.  The technology for graphics cards was outpacing what the games were designed to handle. Sad really. But I suppose all game designers face the dilemma of upgrading graphic capability.
For Freedom!

Offline daglob

  • Shape-Shifting Silly-Putty Android
  • Hero Member
  • Posts: 9745
  • Da Glob
Re: White/Glare out on part of model in game?
« Reply #21 on: June 10, 2015, 09:54:13 PM »
I vote for release. It looks fine on my computer.

Check for gremlins.

Offline SickAlice

  • One-Eyed Willy
  • Hero Member
  • Posts: 2855
  • I'm of a mind to make some mookie.
    • The Litterbox aka MeanJellybean
Re: White/Glare out on part of model in game?
« Reply #22 on: June 10, 2015, 11:21:52 PM »
Released on the X-men page, sorry I was out working in the yard today so I didn't heads up. I'll update the keyframes at least when I get the chance and push it to 1.5.
2.0 once or if I ever resolve the glare issue.